Overview#

DirXML 4.5 is the base version.

Install Issues#

Upgrading to IDM 4.5 SE Using Identity_Manager_4.5_Linux_Standard.iso

NetIQ eDirectory 8.8 SP8 v20805.07 DirXML 4.0.2.7 SE.

From the iso mounted:

./idm_linux.bin
...Launching installer...
connect /tmp/.X11-unix/X0: No such file or directory
... Preparing CONSOLE Mode Installation...
After supplying credentials, I get this error,
Loader Failed:for /opt/novell/eDirectory/lib64/libspmclnt.so,error /opt/novell/eDirectory/lib64/libspmclnt.so: wrong ELF class: ELFCLASS64,errno 2
Loader Failed:for /opt/novell/eDirectory/lib64/libspmclnt.so,error /opt/novell/eDirectory/lib64/libspmclnt.so: wrong ELF class: ELFCLASS64,errno 2

Known Error#

After many emails and me sending information, we got back that it was a Known Issue!
---------- Forwarded message ----------
From: <support@novell.com>
Date: Thu, Apr 9, 2015 at 8:20 AM
Subject: Service Request # 10944218721 : Upgrading to IDM 4.5 SE:User Credentials Not Valid
To: jim@willeke.com
Dear Jim,

With regards to Service Request # 10944218721 (Upgrading to IDM 4.5 SE:User Credentials Not Valid):

Thank you very much for your update and sorry for long delay. I had to contact backline engineer and he informed me that it  is a known error, our engineering team is working to fix it. As workaround I'd like to propose you to use <CD>/products/IDM/install.bin instead for the upgrade. 
....

The problem is being investigated under __"Bug 926557__ - idm_linux.bin fails on RHEL" thread. 

Yes, it is commandline install, more precisely you need to run it with option -console:
.../products/IDM/install.bin -i console
....

Now documented Identity Manager 4.5 installer fails with "Loader Failed:for /opt/novell/eDirectory/lib64/libspmclnt.so"

More Information#

There might be more information for this subject on one of the following:

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-2) was last changed on 13-Apr-2015 11:35 by jim